Announcement Regarding Android 5.0 (SDK 21) and Below

Hello everyone.

As you may already know, we must announce that we are ending support for Android 5.0 (API 21) and below in all forthcoming updates. With new advancements in networking (and Android SDKs) comes new advancements in advertising, so to be able to block ads, we must stay current. Unfortunately, that means some phones won’t be able to follow AdClear’s updates going forward.

In short, Android 5.0 and below are getting old. If it were up to us, we would continue supporting every SDK, but the decision is out of our hands.

The good news is that older versions of AdClear are still available to use. You will still receive updates to ad blocking filters, as well. Thank you very much for using AdClear.

Christian

3 Likes